Yale New Haven Health System

MyChart Minimum Requirements


Windows

Windows XP and Windows Vista cannot be updated to the minimum required version of Internet Explorer needed to access MyChart. If you are using one of these operating systems, please use Firefox or Chrome to access MyChart.

OS

OS X versions 10.6 through 10.8 cannot be updated to the minimum required version of Safari needed to access MyChartPLUS. If you are using one of these operation systems, please use Firefox or Chrome to access MyChart.

Android OS

Android 4.4.2 or higher is required to access MyChart on the web browser. Android 5.0 or higher is required to use the MyChart Mobile app.

iOs

iOS 6 or higher is required to access MyChart on the web browser. iOS 13.4.1 or higher is required to use the MyChart Mobile app for video visits.